SpinWorks

From NMR Wiki

Jump to: navigation, search

author: Kirk Marat (kirk_marat@umanitoba.ca)
download: v3.1.8 (Feb 10, 2011)

Contents

Introduction

SpinWorks is a freeware software package for the processing of 1D and 2D data. Also included are modules for the simulation and analysis of second order spectra, and dynamic (exchange broadened) NMR spectra. 3D Data processed by NMRPipe can also be displayed and printed. (3D processing is under development)

While some processing packages seem targeted to the biological NMR community, SpinWorks' focus is synthetic organic and inorganic chemists. However, SpinWorks does just as good a job at processing 2D BioNMR data as any other package that I am aware of. An effort has been made to create a coherent easy to follow user interface, and to obtain as much processing information as possible from the data set. For many of 2D experiments, simply clicking the "Process" button is all you need to properly process your 2D data.

Available versions

SpinWorks 2.5.5 This is a Win32 version that should run on anything from Windows 95 and up. It also runs under WINE on Linux and under assorted Windows emulators on Macs. Supported data formats are Bruker(UXNMR/XwinNMR/Topspin) and Varian (VNMR/VNMRJ) for 1D and 2D. Tecmag (1D and 2D) and JEOL (1D only) are supported, but not thoroughly tested. 1D spectra can also be saved and read in JCAMP-DX format. This version is in maintenance mode (no further development).

SpinWorks 3.1.8 Runs under the Microsoft .NET runtime environment. Hopefully it will run on other .NET environments as well, such as the Linux mono package (testing under way). The aim is eventually to have the program platform independent and open source. Fully supported data formats are: Bruker (UXNMR/XwinNMR/Topspin), Varian (VNMR/VNMRJ), Anasazi (1D and 2D CDFF format) and JCAMP-DX (1D spectra and FIDs). NMRPipe processed 2D and 3D data are also supported.

MONO testing I am currently (May 2010) testing SpinWorks under the MONO runtime on both Windows (XP and Vista) and Linux (openSUSE 11.1). Results so-far are encouraging, with SpinWorks running on both platforms. However, there are still a number of bugs in the MONO run time - some of which have work-arounds and others do not. An example of this is that MONO seems unable to print in landscape format??? It is likely the Microsoft .NET will always be the preferred environment for SpinWorks on Windows, but MONO will be the environment on Linux. SpinWorks is written entirely in the C# language.

I have also been testing the MonoDevelop IDE on both Windows and openSUSE. SpinWorks compiles and runs (with a few rough edges) on both systems. In fact, binaries produced by MS Visual Studio will run under MONO and binaries produced by MonoDevelop will run under .NET. MonoDevelop may be a very useful tool for those that want to compile and/or modify SpinWorks on systems other than Windows, or for Windows users who don't have MS Visual Studio. MONO and MonoDevelop are being ported to MacOS X, so this would be a way to compile and run SpinWorks on Macs. To me, it looks like the MacOS X versions of MONO and MonoDevelop are a fair bit behind the Linux and Windows versions. For example, the MonoDevelop debugger does not work on MacOS X.

I now (Dec. 2011) have a Ubuntu system with Monodevelop running. I hope to be able to put more effort into the Linux version in the future.

Breaking News: Christian (user bailli) has found a major bug that causes SpinWorks to crash at start-up on some Linux versions. This is being fixed and a new Linux friendly version should be available sometime during the week of Feb. 1, 2010. Thanks Christian! Fixed in 3.1.7 (beta).

Bug! Sept. 27, 2011. On some Windows 7 64 bit systems the print dialog (from either the File menu or the toolbar doesn't work. However, the Print Preview command and the Print button in the Print Preview dialog work fine as a work-around. A fixed version should be available in a few days.

This should be fixed in 3.1.8 beta 4, which was uploaded to our ftp server Sept. 29, 2011. You must, however, select the "use alternate Print Dialog" in the Set Start-up Options... dialog (Options menu)

News

  • Three "Penguin Friendly" (Linux) versions of SpinWorks have been placed in the "Linux" sub-folder of the SpinWorks ftp site (ftp://davinci.chem.umanitoba.ca/pub/marat/SpinWorks). One has been compiled with MS Visual Studio on Windows, another has been compiled with monodevelop on Windows, and the third has been compiled with monodevelop on Linux (openSUSE 11.1). In principle, all three versions should run on all mono platforms (Windows, Linux, MacOS X). In practice, there may be compatibility issues. Things that still need work on Linux:

- Some OS/Printer combos (Linux only) can't print landscape, or have other printing issues such as wrong line thickness, etc. I could really use some feedback here.

- The recent files list doesn't work on Linux (fixed in 3.1.7a)

- 2D processing can be slow compared to running under .NET.

- The simulation modules still need to be compiled for Linux (NUMMRIT is available. The source code must be downloaded and compiled for your system).


Although the Linux versions should run on Windows, a number of Windows-specific features (e.g. the Windows Clipboard) have been disabled in the Linux versions. So, for Windows, please download the most-recent complete Windows version and run under .NET (release 2 or higher).

Bug! Dec. 2011. We have found another but that affects Win 7 64 bit systems, having to do with how this O.S. handles screen refresh. Version 3.1.8.1 is a fixed version. Thanks to J├╝rgen Conrad for pointing out this problem.

Bug! Sept. 27, 2011. On some Windows 7 64 bit systems the print dialog (from either the File menu or the toolbar doesn't work. However, the Print Preview command and the Print button in the Print Preview dialog work fine as a work-around. A fixed version should be available in a few days. This is not a bug in SpinWorks, but a bug in .NET for Windows 7.

This should be fixed in 3.1.8 beta 4, which was uploaded to our ftp server Sept. 29, 2011. You must, however, select the "use alternate Print Dialog" in the Set Start-up Options... dialog (Options menu)

  • SpinWorks 3.1.8 (release) Nov 1, 2011. The release (non-beta) version of SpinWorks 3.1.8 was uploaded to the ftp server on Nov. 1, 2011. There are two new Linux versions as well. One has been compiled with the Mono Develop, while the other has been compiled with MS Visual Studio. Note that I do not currently have a Linux system for testing these versions, so any feedback would be appreciated.
  • SpinWorks 3.1.8 February 10, 2011 Inproved baseline correction routine (Whittiker Smoother). The FID display routine has been improved, and the window function is now displayed with the FID. Small bug fixes.
  • SpinWorks 3.1.7 releases (May 5, 2010) Numerous small feature improvements including improved handling of Bruker T1 (or similar) type data. Also improved JCAMP-DX handling.
  • SpinWorks 3.1.7 (beta) (Feb 8, 2010) Fixed a bug that was causing start-up crashes - mostly on Linux but also occasionally on Windows. Added support for Anasazi format data (CDFF type 2) 1D and 2D.
  • SpinWorks 3.1.6 (November 1, 2009) JEOL 1D data are now supported (2D is in the works). Added cubic spline baseline correction. A stacked trace can now be added to the experimental. Sum as well as "skyline" projections are available.
  • SpinWorks 3.1.5 (August 1, 2009) Minor bug corrections and a few new features. For band fitting, the simulated trace and all of the individual peaks can now be dumped as ASCII x,y files. More keyboard shortcuts have been added (e.g. f for full and l for last expansion) and the baseline point and minimum intensity modes can be exited with the the Enter (Return) key. Error logging/program tracing has also been added.
  • SpinWorks 3.1.3 (June 2, 2009) Minor bug corrections and a couple of new features. Plot option are now saved with processed data, and there is a start up option for ISO A4 size (rather than USA size) paper. Hopefully, all of the decimal separator issues have now been fixed.
  • SpinWorks 3.1.2 Minor bug corrections, mostly dealing with the decimal separator issue.
  • SpinWorks 3.1.0 (release) has been released (February 11, 2009). A number of minor bug corrections since the beta release, but no new features. This version is now .NET clean and should run under mono on Linux or MacOS "as is". It will also run under "parallels" on Macs.
  • SpinWorks 3.1.0 (beta) has been released (November 7, 2008). This release adds display of 2D and 3D processed data from NMRPIPE, Hilbert Transforms, and band fitting (deconvolution). It also treats the issue of using "," vs. "." as a decimal separator in a better way, and has numerous other small bug corrections.
  • SpinWorks 3.0.0 has been released (April 16, 2008). This is the first "official" (non-beta) release of SpinWorks 3

Things that still need improvement:

  • AutoPhase routine needs improvement. Anyone have a good algorithm they want to share?

Future developments

  • Support of more data formats
  • Possibly - 3D processing

Please contact author (kirk_marat@umanitoba.ca) for further information.

Personal tools